Juniper to Cisco PPP T1 Connection (Back-to-Back)

This example will show you how to configure your Juniper SRX or J Series Routers to connect to a Cisco Router acting as a telco Cloud.

First off we need to connect our routers together.

I am using a Cisco 3640 router with the following hardware NM-2FE2W in slot 0 and a VWIC-2MFT-T1/E1 WIC slot 0.  The router is running c3640-ik9o3s-mz.124-23.bin

I made a T1 Cross Over (Back-to-Back) cable.  I used a 6 foot piece of CAT5 cable trimmed the green and brown pairs down to keep them out of the way.  Crimped the cable with the following pin out.

Side of Cable

Pin 1

Pin 2

Pin 4

Pin 5

A-Side Orange White/Orange Blue White/Blue
B-Side Blue White/Blue Orange White/Orange

note: locking tab faces down, pins are facing up

With the above cable you can physically connect 2 T1 CSD/DSU Cards together and get CD or carrier detect, from there you can configure your T1 interfaces.

It does not matter which side you use on either router as it is a simple T1 crossover cable.

Here is the code used on the Cisco side, you have to configure 2 configuration areas the controller and the interface.

The controller area tells the controller on the card which port protocol to use and then enables that area in the config.

.csharpcode, .csharpcode pre
{
font-size: small;
color: black;
font-family: consolas, “Courier New”, courier, monospace;
background-color: #ffffff;
/*white-space: pre;*/
}
.csharpcode pre { margin: 0em; }
.csharpcode .rem { color: #008000; }
.csharpcode .kwrd { color: #0000ff; }
.csharpcode .str { color: #006080; }
.csharpcode .op { color: #0000c0; }
.csharpcode .preproc { color: #cc6633; }
.csharpcode .asp { background-color: #ffff00; }
.csharpcode .html { color: #800000; }
.csharpcode .attr { color: #ff0000; }
.csharpcode .alt
{
background-color: #f4f4f4;
width: 100%;
margin: 0em;
}
.csharpcode .lnum { color: #606060; }

controller T1 0/0     !! This is the controller in slot 0 wic 0 port 0
description Connected to Juniper SRX240H t1-5/0/0
framing esf     !! this sets the line protocol to enhanced super frame
clock source internal     !! this sets the Cisco controller to apply clocking for the link (to mimic telco side)
linecode b8zs     !! this sets the line code to B8Zs Bipolar with 8 Zero Substitution
channel-group 0 timeslots 1-24 speed 64     !! this creates a serial interface Serial0/0:0 to use if you change the first 0 to a 3 then the serial interface would be Serial0/0:3  in rhis example we are utilizing all 24 DS0 channles for a full T1 you could use less by doing 1-8,24 to use DS0 1 to DS0 8 and the signalling on DS0 24 this would give you a 512K fractional T1

The Serial interface area of the Cisco Config

interface Serial0/0:0     !! This is the serial interface created from the controller code
ip address 192.168.64.2 255.255.255.252  !! This is the IP Address on the Cisco Interface
encapsulation ppp     !! make the encapsulation PPP
no ip route-cache     !! turns of IP route cache
no cdp enable     !! turns off Cisco CDP protocol

OK the Cisco Side of the configuration is complete, note you may need to issue no shutdown on the controller and the serial interface as Cisco’s Default is to leave everything turned off (administratively down).

And now for the fun part the Juniper code.  I used an SRX240 in a Active/Passive Cluster but the code is the same for the J-Series as well.

The other side of the T1 Cross Over Cable is plugged into a SRX-MP-1T1E1 Mini-PIM this was plugged into mPIM port 1 of node 0 of the chassis cluster.  This makes the port named t1-1/0/0 – yes 1 as it is the 1st slot in the overall chassis cluster.  Note the  the first mPIM slot in node 1 would be t1-5/0/0

clocking external;
encapsulation ppp;
unit 0 {
    family inet {
        address 192.168.64.1/30;
    }
}

A lot less code eh.  to enter the code its just a single line see below:

set interfaces t1-1/0/0 clocking external encapsulation ppp unit 0 family inet address 192.168.64.1/30

IF you wanted to do each item separately you would enter this following

set interfaces t1-1/0/0 clocking external
set interfaces t1-1/0/0 encapsulation ppp
set interfaces t1-1/0/0 unit 0 family inet address 192.168.64.1/30

the you will see both sides are up up in the cisco term.

See below

Cisco Interfaces

Cisco#show interfaces Serial0/0:0
Serial0/0:0 is up, line protocol is up
  Hardware is DSCC4 Serial
  Internet address is 192.168.64.2/30
  MTU 1500 bytes, BW 1536 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP, loopback not set
  Keepalive set (10 sec)
  Last input 02:37:58, output 00:00:01, output hang never
  Last clearing of "show interface" counters 08:16:59
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 5845
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/5845 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1152 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     59390 packets input, 36873298 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     1 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 1 abort
     61018 packets output, 36895382 bytes, 0 underruns
     0 output errors, 0 collisions, 439 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
  Timeslot(s) Used:1-24, SCC: 0, Transmitter delay is 0 flags
Cisco#

And the Juniper side short check

{primary:node0}
root@SRX240H> show interfaces t1-1/0/0 terse
Interface               Admin Link Proto    Local                 Remote
t1-1/0/0                up    up
t1-1/0/0.0              up    up   inet     192.168.64.1/30

{primary:node0}
root@SRX240H>

And the Extended version

{primary:node0}
root@WPJFW01> show interfaces t1-1/0/0 extensive
Physical interface: t1-1/0/0, Enabled, Physical link is Up
  Interface index: 161, SNMP ifIndex: 539, Generation: 164
  Link-level type: PPP, MTU: 1504, Clocking: External, Speed: T1, Loopback: None, FCS: 16,
  Framing: ESF
  Device flags   : Present Running
  Interface flags: Point-To-Point SNMP-Traps Internal: 0x0
  Link flags     : Keepalives
  Hold-times     : Up 0 ms, Down 0 ms
  Keepalive settings: Interval 10 seconds, Up-count 1, Down-count 3
  Keepalive statistics:
    Input : 2123 (last seen 00:00:08 ago)
    Output: 2158 (last sent 00:00:03 ago)
  LCP state: Opened
  NCP state: inet: Opened, inet6: Not-configured, iso: Not-configured, mpls:
  Not-configured
  CHAP state: Closed
  PAP state: Closed
  CoS queues     : 8 supported, 8 maximum usable queues
  Last flapped   : 2013-07-29 18:54:04 UTC (08:24:23 ago)
  Statistics last cleared: 2013-07-29 21:16:04 UTC (06:02:23 ago)
  Traffic statistics:
   Input  bytes  :             36651982                    0 bps
   Output bytes  :             37574164                    0 bps
   Input  packets:                59399                    0 pps
   Output packets:                59407                    0 pps
  Input errors:
    Errors: 1, Drops: 0, Framing errors: 1, Policed discards: 0, L3 incompletes: 0,
    L2 channel errors: 0, L2 mismatch timeouts: 0, HS link CRC errors: 0, SRAM errors: 0,
    Resource errors: 0
  Output errors:
    Carrier transitions: 0, Errors: 0, Drops: 0, Aged packets: 0, MTU errors: 0,
    Resource errors: 0
  Egress queues: 8 supported, 4 in use
  Queue counters:       Queued packets  Transmitted packets      Dropped packets
    0 best-effort                55115                55115                    0
    1 expedited-fo                   0                    0                    0
    2 assured-forw                   0                    0                    0
    3 network-cont                4292                 4292                    0
  Queue number:         Mapped forwarding classes
    0                   best-effort
    1                   expedited-forwarding
    2                   assured-forwarding
    3                   network-control
  DS1   alarms   : None
  DS1   defects  : None
  T1  media:            Seconds        Count  State
    SEF                          0            0  OK
    BEE                          0            0  OK
    AIS                          0            0  OK
    LOF                          0            0  OK
    LOS                          0            0  OK
    YELLOW                       0            0  OK
    BPV                          0            0
    EXZ                          0            0
    LCV                          0            0
    PCV                          0            0
    CS                           0            0
    LES                          0
    ES                           0
    SES                          0
    SEFS                         0
    BES                          0
    UAS                          0
  HDLC configuration:
    Policing bucket: Disabled
    Shaping bucket : Disabled
    Giant threshold: 1506, Runt threshold: 0
    Timeslots      : All active
    Line encoding: B8ZS
    Buildout       : 0 to 132 feet
    Byte encoding: Nx64K, Data inversion: Disabled, Idle cycle flag: flags,
    Start end flag: shared
  DS1 BERT configuration:
    BERT time period: 10 seconds, Elapsed: 0 seconds
    Induced Error rate: 0, Algorithm: 2^15 - 1, O.151, Pseudorandom (9)
  Packet Forwarding Engine configuration:
    Destination slot: 1
  CoS information:
    Direction : Output
    CoS transmit queue               Bandwidth               Buffer Priority   Limit
                              %            bps     %           usec
    0 best-effort            95        1459200    95              0      low    none
    3 network-control         5          76800     5              0      low    none

  Logical interface t1-1/0/0.0 (Index 82) (SNMP ifIndex 606) (Generation 152)
    Flags: Point-To-Point SNMP-Traps 0x0 Encapsulation: PPP
    Security: Zone: trust
    Allowed host-inbound traffic : bootp bfd bgp dns dvmrp igmp ldp msdp nhrp ospf pgm pim
    rip router-discovery rsvp sap vrrp dhcp finger ftp tftp ident-reset http https ike
    netconf ping reverse-telnet reverse-ssh rlogin rpm rsh snmp snmp-trap ssh telnet
    traceroute xnm-clear-text xnm-ssl lsping ntp sip r2cp
    Flow Statistics :
    Flow Input statistics :
      Self packets :                     55106
      ICMP packets :                     55106
      VPN packets :                      0
      Multicast packets :                0
      Bytes permitted by policy :        36591986
      Connections established :          34173
    Flow Output statistics:
      Multicast packets :                0
      Bytes permitted by policy :        36592742
    Flow error statistics (Packets dropped due to):
      Address spoofing:                  0
      Authentication failed:             0
      Incoming NAT errors:               0
      Invalid zone received packet:      0
      Multiple user authentications:     0
      Multiple incoming NAT:             0
      No parent for a gate:              0
      No one interested in self packets: 0
      No minor session:                  0
      No more sessions:                  0
      No NAT gate:                       0
      No route present:                  0
      No SA for incoming SPI:            0
      No tunnel found:                   0
      No session for a gate:             0
      No zone or NULL zone binding       0
      Policy denied:                     0
      Security association not active:   0
      TCP sequence number out of window: 0
      Syn-attack protection:             0
      User authentication errors:        0
    Protocol inet, MTU: 1500, Generation: 166, Route table: 0
      Flags: Sendbcast-pkt-to-re
      Addresses, Flags: Is-Preferred Is-Primary
        Destination: 192.168.64.0/30, Local: 192.168.64.1, Broadcast: 192.168.64.3,
        Generation: 169

{primary:node0}
root@SRX240H>

 

Have fun….

Advertisements
This entry was posted in Back-to-Back, Cisco, Clocking, PPP, Serial, T1 and tagged , , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s